App not starting properly

Something strange is happening, I went from a app that is nearly done to an app that starts, but gives me an hourglass and then shuts down.

I tried opening a backup I made last night (it worked fine then) and am getting the same thing. The odd thing is that some older backups are running fine … compile … .run OK.

I did clean Rebuild Project, uninstalled C8, reinstalled, did TPSFIX scans (no problems noted) and am still seeing the same result.

Even odder is that sometimes when the app is trying to start, it opens a browse window that is only called through a menu. Hourglass still present and then shutdown.

I am lost and not liking that I may have to start form an older version.

p.s. after the reinstall, I noticed that C8 did not aske for a S/N
. Are there registry values that could affect this weird behavior?

Sorry for being so needy on the forum.


I am getting this error when I am trying to run the app in debug:


The culprit (and I dont understand why) :

The DO RefreshWindow call in the middle of a long list of lookups torpedoed the whole thing. It got stuck in there last night and I got called away from the computer. Totally forgot about that change.

thanks to those that looked.