Clarunext.dll could not be copied

HI folks.
My next issue is’clarunext.dll could not be copied. Error: The process cannot access the file because it is being used by another process.’
It is a brand new windows 10 VM with only Clarion 11 installed.
What could be using the file?

Have a look in task manager. Sometimes theres a hidden copy of a program still in processes

Thanks but no.
I’ve restarted the VM and I can’t see anything running that shouldn’t be but I still get the error.

Actually I seem to remember have all sort of problems one time that turned out to be because the windows user was administrator, which made a great mess of the file and folder permissions due to owner conflicts

Hi Marc,
I looked in the code for this error message and found it.
To my surprise, the error message is not correct. It has nothing to do with the file could not be copied.
I finally figured out the error and how to fix the problem.
The error is a loading error.
I had one computer (my desktop) that worked fine and one computer (Windows 2016 Server) that didn’t work.
I copied the msvcr120.dll from the computer that worked to the computer that didn’t work and that solved the problem.
The file is located in C:\Windows\SysWOW64. I copied it to my application folder on the computer that didn’t work.
Here is the little source program I wrote to figure it out.

ClaRunExt_LoadLibrary(CONST *CSTRING pszModuleName), |
ClaRunExt_GetLastError(), ULONG, PASCAL, NAME(‘GetLastError’)

ModuleName CSTRING(‘ClaRunExt.dll’),PRIVATE

h# = ClaRunExt_LoadLibrary (ModuleName)
e# = ClaRunExt_GetLastError()
IF h# = 0
MESSAGE(‘Get last error = ’ & e# & |
‘|’ & ModuleName & ’ failed to load.’, |
‘Load Library: Win64Api’, ICON:Exclamation)
MESSAGE(ModuleName & ’ loaded successfully.’ & |
'|Address handle = ’ & FORMAT(h#, @n14) & |
'|Get last error = ’ & e#, |
‘Load Library: Win64Api’, ICON:Asterisk)

LoadLib.clw (768 Bytes)