Getting WSLKEYB GPFs, does anyone know any trips to get Clarion6 running on Windows 8(.1)

Win 32bit of course but I have a situation where it is crashing a lot. WSLKEYB kind of errors. One particurlary repeatable situation is creating a new procedure, go to embeds, hit insert and boom up comes the WSLKEYB error.

The desktop is hosted by hyper-v and accessed by remote desktop.

I know this is probably asking a lot of poor old C6 but at the moment I can’t move this application away.

Any hints?

Here at our factory we couldn’t make it run on the Windows 8.1, that’s why we migrated to the Clarion 9.1.

If anyone know something that could help, I would appreciate it too!

Damn, that sucks! I use Vista quite successfully with C6 but in this case the sysadmin installed 8.1

What kind of issues were you seeing Ramon?

Another piece in the puzzle…

I just discovered that this particular GPF is 100% resolved by reducing the screen resolution.

1680x1050 is ok
Edit: 1716x979 is ok too (host is 1920 x 1080, VM Guest in windowed mode with library panel open on the left)
1916x979 or higher = GPF

My VM doesn’t give me any option to select values in between those two so I am not sure more precisely where the limit it. I guess this is some 16 bit related hard limit of the embed editor!

1 Like
Paul Attryd hit this error, in May 2001 - apparently in CW20,
He felt it was related to typing “too fast”

In this case it was the IDE itself and always occurred when entering the embed editor (embeditor?) so before you could even start typing.

In the case of Paul a great sledge hammer solution would be to lower the repeat rate on the keyboard via the OS. I am sure the users wouldn’t mind… :smiley:

I had a friend having GPF issues in C6 when trying to edit embeds in C6 in Windows 10 on a Surface Book. Changing the resolution did the trick. Thanks for the post @brahn

1 Like

I had the same issues and this fixed it. I also tried adding more memory to the display also fixed the issue and I could keep the higher resolution.

1 Like

alguien podría facilitarme el archivo CW2RUN32. DLL, en un archivo ZIP??

Hi Fernando,
Not sure if such a large zip can be directly added here so this may not work… (324.7 KB)

File dated 18/04/1997 Version 2.003

1 Like

hola a todos, tengo un problema con una aplicación vieja que me da como mensaje, RUNTIME ERROR, INTERNAL ERROR 01: WSLKEYB, eso ocurre cada ves que hace un Report Preview, cuando lo envió a imprimir directo trabaja normal, hay rutinas que pasan de manera obligatoria por el Report Preview

agradecería cualquier ayuda el respecto