Softvelocity newsgroup not working? - Thunderbird setting change required

Using thunderbird 102 using the SV news server certainly seems to have an issue. The name resolves to an IP, but it doesn’t respond to pings (although I don’t know if that’s considered normal or not?)
Can anyone here confirm the news server is working, and what IP they’re using to access it ?

1 Like

I just connected now (5:34PM PDT 7/21/2022) connecting to, which resolves to (but does not answer PING).
That is the same IP resolved for

I am also on Thunderbird 102.0.3 (32-bit) and not having any luck getting messages here in Australia.

Hi Abdullah,

I can’t speak for thunderbird 102, but the news server is definitely up. On the wednesday webinar this week, Paul was also trying to set it up, but seemed to have an issue. You might want to review that here;

His issue seemed to mainly be around his password.

If you have NetTalk, then run the NetDemo example (\examples\nettalk\demo\ - there’s a Get News window in there where you can enter your details and check.
Port: 119
TLS : Off


PS - PING means nothing. PING uses a protocol called ICMP, and this is explicitly turned off for many (most?) servers.

oh in that case I am starting to think there is an issue with this new version of Thunderbird. Is anyone successfully using Thunderbird, and if so then what version?


Bruce, what version of Tbird are you using? I’m beginning to think 102 has a problem with the SV news server (or vice versa)

OK, TBird 102 does not connect to the SV news server, 78.14 and 91.11 do. I’m wondering if maybe the news server host software that SV is using doesn’t like the fact it’s getting a 3 digit version #?

I’m finally able to have a chance to test it, and it is working OK with Agent 7.2.

I’m connected to via

I’m also using Agent 8.00/32 1272, Jeff, and working all OK for me also.

Release notes for TBird 102 have a note about newsgroups:

New Javascript NNTP implementation enabled by default; Set mailnews.nntp.jsmodule to false to disable

Maybe the ThunderBoys should try that? (Or switch to Agent :upside_down_face: )


Sounds like there may be a problem in the latest.

I found this official folder with all older releases of Thunderbird.

91.11 looks to me like the last non-beta before 102

Thank you Jane, I missed that. Changing mailnews.nntp.jsmodule means that TBird 102 can now connect to the SV news server again.


Where and how do you change that setting please?

Got it… Kind of tricky… go to Tools, Settings, in General Search for Config Editor, click on the Config Editor button, in the search type jsmodule, double click on the mailnews.nntp.jsmodule and it should turn false… close the program.


So I wonder what made it break “now”? Could it have anything to do with the lack of a valid certificate? (I did send them an email about that, btw). Is there some other previously-provided-but-now-missing dependency that TBird had?

No, looks like TBird changed their default NNTP code to a nntp-js implementation by default. Changing mailnews.nntp.jsmodule turns it off and goes back to whatever they were doing before.

1 Like

Yes. But I agree with Jeff’s question.
WHY does the nntp-js implementation not work?

It apparently works for a lot of people.
But there are complaints online such as this thread:[email protected]/msg1861377.html

Somewhere in those posts is this speculation, which may tie in with Jeff’s question about lack of certificate:

– My guess right now is that something along with the ciphers you use
–isn’t accepted anymore.
I am pretty sure no. This nntp server has no encryption configured (it
is my small home server.)

I just used this and it worked. The instructions were very helpful, but needed formatting:

  1. Press and release Alt key to get Menu Bar
  2. Tools Menu
  3. Settings (last item)
  4. In General in Search box type: Config Editor
  5. Click on the Config Editor button
  6. In the search box type: jsmodule
  7. Double click on the mailnews.nntp.jsmodule and it should turn False
  8. Close the program

I kept looking in this Post but it does not have these instructions:


Turning jsmodule off works, but i get a timeout after about 10.000 messages from a group

I had that issue too. Kept pressing “get messages” until it was done. Not sure the proper way to get around that.

1 Like