[SOLVED] Unresolved external when adding extra parameters to function

After adding two new parameters (tried both optional and not optional) to an existing function I constantly get the error
“Unresolved External BLABLA@FlsbsbllOsb in BLABLA.obj”

I generated the INC file, I am sending the two new parameters with the function call.

Can somebody help me out with this?

you add only parameters or something more …i.e. additional code inside “blabla”? If yes, check this code …
Clarion have to correctly compile your new procedurę before see new prototype

If you made changes to the INC file , you have to quit your app and reload to get the latest version loaded or go to use the “Refresh Application Builder Class Information” on any class tab.
CLW’s are reloaded every time you compile, not the INC’s that are loaded only when you open your app.

Didier

@dgleduc I started the Clarion IDE today and got the same compile error…

@Jacek_Kosinski The code works when I call the function in another procedure in the same app.
But when calling the function from another app, that’s where it goes wrong…

The app has already been added as external lib in the app with the calling procedure.

It seems to be working now!
Deleted the map and obj folders and generated the code off both apps again and set the configuration to release instead of debug.

Weird solutions but ok.

Solution often used.
Good for you

Good luck

Didier