Browse does not like forward slash in data

Afternoon all

Any ideas why my Browse does not like forward slashes in the data?

The field is a varchar(10) in the database and a CSTRING(11) in the dictionary. If one entry contains a forward slash then I get an error(01S01) attempting to access a record from the file.

The browse worked fine on SQL Anywhere but I’ve had issues since the conversion to SQL Server.
The only that’s changed is that the it’s reading from a view rather than a table.
I can capture the query in SQL Profiler and it looks good and returns data when I run it in SSMS but the application throws the error.

Does anyone have any ideas?


I think - could be wrong - that’s a truncation error. Try changing the length of the varchar.

No idea, Marc. I can put slashes in SQL data with no problem.

Are you using the ODBC driver or SQL driver for your tables? Maybe try SQL. Also, what version of Clarion?

Or find 01s01 on this page: What the Driver Does - ODBC API Reference | Microsoft Learn

Clarion 10, MSSQL driver.
I have one or two other screens which show some of this data and show it data fine but they are populated from queues.

Have you tried a driver trace?

I wonder if something needs escaping, or something.

How would I do either of those things?

OK. I found the trace and got it working.
It does say that it’s a truncation error.
I increased the cstring to 21 characters in the dictionary but no change.
If the issue is to do with needing to escape the slashes how would I go about doing that?

Je suis un crétin.
One of the fields in the dictionary was a cstring 5 but the filed in the db was a varchar(5). I read that it was a string 5.
Thanks all for your help. The trace is very useful but how do I turn it off?