C11.1 13788 Will not build datadll

Hi All. After upgrading my C11 13505 to C11.1 13788 I appear to have @Glenn problem. My Data DLL will not compile.
It generates source ok. But when it comes to compile it reports all ok except there are NO obj or dll generated. Using a cmd and doing dir I can see obj being created, but 0 length and then gone.

After 3 installs of C11.1 I even decided to create a new datadll with just a frame and all files generated. Still no go.

Now to make it really interesting:
Other Dlls in the solution compile fine.
AND if I switch the dll to exe in project properties it compiles!

Anyone got any ideas?
Attached project app fails to compile but looks like to suceeds. If it compiles there should be errors

temp.zip (106.5 KB)

Hi @seanh
I changes this in the Project Options and it started to generate what may happen that is not compiling

After that, it does not compile because of this.


Hope it helps

Hi Sean

I downloaded your application.

Added StringTheory to the globals and the missing global variables in your DCT.

I had to fix ABPRDF.CLW in the Clarion\LibSrc\Win directory because of the << issues 13788 introduced.

After that I get a full compile. dqhdata.dll is created 3394KB. dqhdata.obj is created 55KB

I hope that helps.


Thanks Guys, Must be my setup somehow because I don’t get any errors at all. Source gets generated but no obj created, no dll, nothing.

1 Like


I get the exact same, revered back to previous release and the data dll compiles without any problems.

What I tried and still not working. Maybe try this maybe it will work for you?


Thanks for that. Yes it appears to be the same problem.
I’ve just done one lot of testing with a basically empty app and it still occurs.
HOWEVER a bog std install with no accessories appears to work! As soon as I register all my templates I’m back to nothing again.
So I suspect there might be a rogue template that this version does not like

How did you “I had to fix ABPRDF.CLW in the Clarion\LibSrc\Win directory because of the << issues 13788 introduced.”?

I literally added an extra < to all the places where the error was occurring so

CharToReplace[13]= CHR(141);ReplacedBy[13]= ')<A8>(';LenReplacedBy[13]= 6 !Original
CharToReplace[13]= CHR(141);ReplacedBy[13]= ')<<A8>(';LenReplacedBy[13]= 6 !Fixed

Thank you Mark! I have recomplied and this work around seems to clear this particular issue.

Hi Marius
I chased this a bit, even installed a new 11.1 on a new VM and it worked… until I registered my assesories dir. Fail everything after that.

I’ve also reverted to 13 505

So, I think I know what is happening. I’ve reported as PTSS #43296.

What I noticed is that if an include file is missing, the compiler does not report an error (which it used to do) - but also does not create the OBJ. Which in turn means the Linker then also (silently) fails because of the missing OBJ.

I was able to duplicate in any app or project by adding
the compile reports no errors, the linker reports no errors.

I don’t think there’s any real way to discover which file is missing, so for now I recommend reverting to an earlier build if you have this issue.


Who would have thought this would end up being the bleeding edge.


I was going mad. :slight_smile:


I still get the same with 11.1.13810, can you confirm on your side also please?

Hi Sean,

Have you tried with the new version 11.1.13810 yet?

Hi Marius,

On my side the test Exe is being created. Which may suggest there may be some other issue in play. The include issue seems to have been fixed, but maybe there is something else as well.



Thank you, I came across the creator of my problem(s), TABOGA Barcode Library. As soon as I remove this template globally it works.

I have send the problem thru to them, but will try to fix in the mean time.

The strange thing is, no errors are created…

So the error has to do with the incorrect use of the INCLUDE statement, and yes that needs to be corrected, but I have posted the problem (with an example) as PTSS# 43312.

The short version, if you encounter this problem, make sure all INCLUDE statements include the ,ONCE attribute. If you fail to do this, and there is an include loop, then you can see this compiler failure effect.

Kudos to Alberto Michelis who posted me the example.

1 Like

Hi Marius,

I haven’t received it. Taboga Software products have been taken over and maintained by FominTools. Haven’t you reported the problem to support (at) fomintools (dot) com?

BTW, the latest Taboga Barcode Library release has this problem fixed as well as other issues reported.

Kudos to Bruce who has nailed down the issue.

Thank you, but the email " support (at) fomintools (dot) com" keeps on returning? Send to “oleg (at) fomin (dot) info” also. Let’s see if that works.