C11 odd behaviour not returning. possible bug?

c11
Tags: #<Tag:0x00007f46da4ff290>

#1

Hi All

I have a really odd behaviour in C11 that I’d like help with.
I have a browse, that calls a form. In the .Kill method I call another form to change a date. Stock standard, no embed code, just a single spin with a date and an ABC calendar button.

This has been working fine.
Up to putting in C11 a couple of days ago.

Now I can freeze the prgram by clicking on the calendar and selecting a date. It never returns

So I’ve traced this as far as I can.
Now unless I’ve missed something clarion simply isn’t returning out of the class !!! Code below

As a side note I’ve had reports of screens returning to a different thread in stead of going back. I’m wondering if this is part of that.

I have this code around the call:

   ud.Debug('Go to  calendar')   <--- This displays
  Calendar10.SelectOnClose = True
  Calendar10.Ask('Select the date of next contact',FIR:NextContact)
  ! [Priority 5030]
  ud.Debug('Return from calendar')<----- This does NOT

In Calendar10.ask I have:
ud.Debug(’ calendar before parent’) <— This displays
! Parent Call
ReturnValue = PARENT.Ask(pTitle,pDate)
! [Priority 5001]
ud.Debug(’ calander After parent’)<— This Does NOT

I’ve altered ABUTIL.CLW to enable output to debug string and have put this in Calendarclass.ask

    OutputDebugStringz('Calander 1') <---- This Displays
    RETURN PARENT.Ask(pTitle,pDate)
    OutputDebugStringz('Calander 2')  <----- This Displays

And this at the very end of CalendarBaseClass.ask

    OutputDebugStringz('Calander 9 ')   <-----  This displays
    RETURN(loc:fecha)

Sean H


#2

Have you tried stepping through it with the debugger?


#3

Yes, but oddly that locks up even earlier! So no I couldn’t use it. I did try looking at the disassembly code, but that all looked kosher.
Been talking with bruce and it might be an ezhelp problem


#4

I noticed a different behaviour in a C11 browse (ABC) as well.
In my case when deleting a record from a browse, i checked certain child record(s) and if there are child records i throw up a message that deleting is not OK and return to the browse.
This worked okay in C6.3 and also in C10.
What i see now in C11 is that the message displays, but in the background the form (for confirmation of the Delete) shows up anyway and then the app freezes with the message coming up again and again.

Probably the embed point in the browse (and the action after that) has changed in some way, i had no time yet to figure that out.
So i would suggest you take a look at the browse itself.


#5

Maybe comparing the generated code between versions would be a good thing to get out of the way.


#6

SOLVED -ish Turns out that turning off ezhelp in the app did in fact stop the freezing.

It would appear that interactions between ezhelp, winevent, and C11 may get tangled.

I’ll continue testing but all seems ok so far.