Clarion 11 13401&13372 I can´t select any control templates to drop them onto a window


#1

I open a window (or create a new), the control template list is showed up correctly but I can´t select any of the control templates to drag&drop it onto the window.

No matter if it´s an existing or a new app, I have no possibility to select a control template. Nothing happens when I try to click on one (no selection bar, nothing).

I tried everything in the meantime:

  • New installation of Clarion11EE_installer-11.0.13401.exe, on clean installed Win10-32 and Win10-64
  • Also a new Installation a different PC (Win10-64)
  • C11 ‘typical installation’ no 3rd party stuff, nothing

Now I tried to find out since when this problem happens and I installed older Clarion versions - result:

  • Clarion11EE_installer-11.0.13401.exe BAD
  • Clarion11EE_installer-11.0.13372.exe BAD
  • Clarion11EE_installer-11.0.13244.exe GOOD

The 13244-Version was the one with the terribel flickering control template box. Then SV changed it which, in my case, leads to this new problem.

I´m wondering because every developer must have this problem. The difference with me could be that I use a German Windows version. I can´t believe this, but could this be the reason? Is there anybody out there using a german Windows 10 with C11-13401 and can select control templates? Can all others select control templates?

Thank you for your feedback.


#2

There’s a bug with users that are using any language except English. Try sending an email to SV support to get a language resource file that works for your preferred language. Should be fixed in the next release.

There’s a thread about this in the C11 newsgroup.


#3

Hi Jeff,

thank you for your answer.

I have added my problem 12 days ago to the clarion problem tracker and also send the clarion support an email, but actually I’m not surprised to have not received an answer from SV yet, as they are always busy being the company with the worst support for their customers. Probably SV only has time to send Core Subscription invoices.

Unfortunately I don’t have access to a newsgroup.

So if there is someone who can help me directly with this, I would be very grateful.


#4

You’re supposed to wait until you don’t need help anymore before you fire your cannons.


#5

Usually yes, but I have requests about problems in this ProblemTracker that have been waiting for answers for years :sob:

Unfortunately, right now the situation for me is simply that I can’t work with the last two versions at all.

What does the newsgroup article say? Is there the language file or where could I download it?

I am grateful for any help.


#6

(edited to remove email addresses)

Lee White updated the .resources files and put them on his website. As he says, be sure to back up before applying these changes.

The problem was that the word “Pointer” was also translated from English, but Clarion needed to find the actual word “Pointer”. e.g. for Spanish it was “Puntero”.

Apparently it does fix the problem so I went ahead and updated these:

StringResources.es-mx.resources
StringResources.pt.resources
StringResources.pt-br.resources
StringResources.tr.resources
StringResources.cz.resources
StringResources.hu.resources
StringResources.it.resources
StringResources.kr.resources
StringResources.no.resources
StringResources.pl.resources
StringResources.fr.resources
StringResources.nl.resources
StringResources.se.resources
StringResources.de.resources
StringResources.es.resources

You can download the zip here…
http://cwaddons.com/temp/PointerUpdatedResources.ZIP

Please remember to rename your existing .resources file before
unzipping the updated file… just in case.

The only change was resetting SharpReport.Toolbar.Pointer to Pointer
in all files.


Lee White

RPM Report Viewer.: http://www.cwaddons.com/products/rpm/
Report Faxing…: http://www.cwaddons.com/products/afe/
—Enroll Today—: http://CWaddons.com

Creative Reporting: http://www.CreativeReporting.com
CRT (cpcs) Support: crt-tech @ CreativeReporting.com

Product Release & Update Notices
http://twitter.com/DeveloperPLUS

Here is a message from Diego that also might be useful:

Hi All,

So to be clear, this only affect users that do not use the English language in the IDE.
Unfortunatly the only fix for now is to use the IDE on English.
But it will be fixed on the next build.
The problem is a manifestation of a bug that existed since C7 and just now was
hit thanks (but unfortunate) to an improved process.
But as I said, it will be fixed on the next build, also the good news is that
the changes make the IDE speadier new process to work on any language as it was
designed to be.
Just till then … english on the IDE or change the none english string resources.
To change the resource:
Open the IDE
Open the language you are interested in from the folder:
C:\Clarion11\data\resources
Like StringResources.es.resources

then search for

SharpReport.Toolbar.Pointer

and change the content from “Puntero” (in spanish resource file) by “Pointer”
(all with out the “”)

Same in other languages.

Regards,
Diego Borojovich
www.Softvelocity.com

On Sat, Mar 23 2019 1:06 pm, Diego Borojovich said:

Hi Franz, Roberto, Mauricio ,Alberto and all,

Finally after a lot of testing in multiple OS, computers and configuration we
were able to reproduce the problem.
Quick fix is to change the IDE language to english, this is not related to the
OS version or OS language, only IDE language.
And it does not affect the IDE while in English language.
I already passed all the info to the team to start working on a fix.
Sorry for the inconvenience.

Regards,
Diego Borojovich
www.Softvelocity.com

On Sat, Mar 23 2019 10:22 am, Roberto said:

Diego,

If you change the Language to any other language that is not English,
the control templates tab does not work, the tree works, but the search
bar does not and the selection of a control template nos not work
either… please fix…

Best Regards…

Roberto Renz

On 3/22/2019 12:58 PM, Diego Borojovich wrote:

Hi,

So what did you change to make it works?
I try to reproduce it with out success.
On Win7 works fine, on Win10 works fine, on Win7 with Clasic style (NT style)
and Win7 style (themed)
docked, no docked, but always worked.
Tha tis why I’m asking what did you do to make it work, or actually what
setting did you have on your windows that make it fail.

Regards,
Diego Borojovich
www.Softvelocity.com

On Fri, Mar 22 2019 7:58 am, Franz said:

Thank you very much, Mauricio. Now it run’s.
/Franz


#7

great it works :+1:

Many thanks to all those who had something to do with this solution and its circulation :pray: