Clarion 11 - Build Server - "This version of Clarion is not registered"


I’m trying to automate a Clarion build process using TeamCity running on a Windows Server 2019/64bit server. I’m getting a strange issue:

I installed Clarion 11 and when I go to the command line and test by running ClarionCL.exe /tl I get an error “error CLCE007: This version of Clarion is not registered”. But if I open a command prompt as an administrator then it works fine.

Same with running the Clarion11 app. If I run as a normal user it loads the splash screen and disappears. But if I do a “Run as Administrator” then it runs fine.

The build process is running as “Local System” which is an administrator (and have tried running as a user in the administrator group) but I get the same issue - error if not run as administrator.

Anyone else come across this or have any ideas?


1 Like

is it set up with /ConfigDir on the shortcut?

As Jeff points out, if you’re using the /ConfigDir switch on the desktop shortcut then your registration details won’t be in the default %AppData% location but will be in a \Settings folder below the \Bin folder.

Fortunately there’s an undocumented switch for ClarionCl that will help…

Try ClarionCl.EXE /tl /configDir

Thanks Graham, tried that but no luck.

As i mentioned, it works when I run a command line as Administrator but not if I don’t. Both cases %appdata% points to the same place and so both cmd.exe prompts are exactly the same except the elevated permissions. I wonder if it is something to do with domain security settings…

Fun (not)

Where have you installed Clarion - I don’t recommend you install into ‘Program Files’ - better to install into it’s own folder off the root eg (for Clarion 11 13505) c:\CW13505

Clarion doesn’t now require elevation to run the IDE (Clarion 9.1 and earlier did) so if you get that sorted out I expect ClarionCL to work as well.

What Build of Clarion 11 are you using?

Hi, its installed into C:\Clarion\Clarion11 and is build 13630. It put the settings into user\appdata\roaming (that’s where %appdata% points to).

I am wondering if it is something to do with the domain user I am logged in as?

Found the issue. Good error reporting on Clarions part of course. the problem was permissions. Clarion didn’t have write access for some reason to the log files and so errored with the Not Registered error.

Thanks for all your help folks

1 Like