Clarion 11 IP Driver

clarion-ip
Tags: #<Tag:0x00007f46ddcc6840>

#1

Hello fellow Clarioneers!
I just recompiled a working IP enabled Clarion 10 app in Clarion 11- no compiling errors.
Upon execution, the App stops with the error " OpenSSL initialization failed"
I do not know where to look to resolve this. In fact even the Peoples app give the same error. I have copied the client.pem to the app folder and the server.pem to the clariondataserver folder. But error persists. Changed the port in the app, but problem persist.
Any help would be appreciated.
Thank you
Fouche


#2

Have you looked at the manual: C:\Clarion11\docs\IPdriver\IPDriverRef.pdf - page 29 shows some information


#3

Hello,
Thank you for the response. I did have a look, but I must admit without documentation on how to add or include such a 3rd party product, I am a lost… I really do not know where to start.
It would be lovely to have a step by step guide on how to implement an OpenSSL file/certificate.


#4

Resolved! yippee!
This was easier than I thought.
Step 1:
go to https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/
Download [libressl-2.5.5-windows.zip] 09-Jul-2017 09:56 6126796(https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.5.5-windows.zip)
Step 2:
Extract the libtls-15.dll and libssl-43.dll Files from the …libressl-2.5.5-windows\x86 to your Application folder.
Step3:
Copy the client.pem file from c:\clarion11\examples\ipdriver to your application folder and the server.pem file to the C:\ClarionDataServer folder. (Without client.pem it also worked-not sure why)
Step4: Change the port in app to 2340.
Viola!
I then discovered that the lib##.dll files already existed in the C:\ClarionDataServer folder.