Clarion IDE Error - Could not gain access to app after 50 attempts

Tags: #<Tag:0x00007f2251e68d20>

Hello Forum Members,

While opening a file in Clarion 11 IDE i am getting following error(s),

image

image

Any solution to this would be greatly appreciated.

I saw that today when I tried to open an app that was already open in another Clarion instance.

1 Like

What Jeff said. You have it open in another Clarion IDE or another user on the network has it open. If not look in TaskManager Details for Clarion.EXE running that is a zombie and kill task.

Once I get that message, I always shutdown that instance of the IDE. I can’t recall exactly why but it seems like it corrupted something so it not longer worked right.

Hi @jslarve,

Also, i am getting this error while opening code into clarion source embeditor :slight_smile:

Clarion Version : 11.0.0.13505
.NET Version : 4.0.30319.42000
OS Version : Microsoft Windows NT 6.2.9200.0
Current culture : English (United States) (en-US)
Working Set Memory : 295156kb
GC Heap Memory : 29189kb

Unhandled exception
Exception Type: System.NullReferenceException

Exception Type: System.NullReferenceException

Exception thrown:
System.NullReferenceException: Object reference not set to an instance of an object.
at System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object args, Boolean synchronous)
at System.Windows.Forms.Control.Invoke(Delegate method, Object args)
at ICSharpCode.SharpDevelop.Gui.WorkbenchSingleton.STAThreadCaller.Call(Delegate method, Object arguments)
at ICSharpCode.SharpDevelop.Gui.WorkbenchSingleton.SafeThreadFunction[A,R](Func`2 method, A arg1)
at SoftVelocity.Generator.UI.ApplicationMainWindowControl_ViewContent.OpenEditor(EditorInfo einfo)
at SoftVelocity.Generator.UI.ApplicationMainWindowControl_ViewContent.OpenPwee(IPweeDetails generator)
at SoftVelocity.Generator.UI.GeneratorBinding.OpenPwee(IPweeDetails generator)
at Clarion.GEN.GeneratorUI.OpenPWEE(GeneratorUI* , IPWEERequester* gen)

You got this once, or every time?

It’s probably once in which case … well the IDE crashes sometimes. Close the IDE, reopen, open APP and select Recover. I usually backup the folder first incase Recover is bad, which is rare. That way I have the APP BPP and last generated CLWs to compare to see if I’m missing any changes since last gen.

Yes, @CarlBarnes, I face this every time once i open the source, it crashes,

Any solution just because this way i would have lost my changes.

Hi @jslarve

Do we have any solution for this issue?

PWEE is an old acronym for “Procedure Wide Embed Editor”. I wonder if you have a “weird” character in an embed somewhere. Or maybe some other corruption.

One way to get “weird” stuff in there is to copy code from a web browser (such as from github), then paste into the Clarion editor. Sometimes it attempts to convert your document to unicode. Not sure if that behavior exists within an embed or just the plain text editor.

Have you tried exporting to TXA then importing into a new app?

1 Like

Sometimes, I get weird errors trying to open an app. Like today, as soon as I opened the app it wanted to know if I wanted to save changes, I hadn’t done anything yet! A lot of time the compiler goes wonky. “ENDING” clarion.exe from task manager when it decides to go into the background might be enough.
But I just reboot, and for good measure I issue an “ERASE C:\Users\your_windows_userid\AppData\Local\Temp*.*” before opening Clarion IDE, again. This happens once every couple of months. For a while it was on a weekly basis. So, I setup a batch file in my source folder that I run to do that erase. I also have another batch file to erase the TopScan.ini file for when TopScan.exe decides to play hide-and-seek: “erase C:\Users\risaf\AppData\Roaming\SoftVelocity\Clarion\11.0\TopScan.ini”

Sometimes the app is altered-on-open. This is most common when opening an app made in an earlier Clarion. Clarion auto-converts the app, and/or dict to the latest version for that IDE. Since this is a “breaking change” it’ll ask first.
Another breaking change is if a template is missing from your registry, that the app is used. So, for example, say one of my examples has GPF Reporter in it, and I open it in an IDE that doesn’t have GPF Reporter registered, then it’ll note the missing template in the output pad, and confirm saving the app in this “changed state”.

Cheers
Bruce

Yes i tried it, but no luck!

Perhaps you could examine the txa to see if there are any extended characters in there. They can definitely screw things up. Otherwise, not sure what to suggest next.