Clarion5 error on compile

I have a clarion app that has compiled fin in the past. Now when I try to Make, I get a popup that says:
“clarion for windows err.$$$(1) #3: cif$fileopen makem001.obj The system cannot find the path specified.”
As far as I know nothing has changed. The content of my red file is:

– Default Redirection for Clarion 5

*.obj = %ROOT%\obj
*.res = %ROOT%\obj
*.rsc = %ROOT%\obj
*.dbd = %ROOT%\obj

*.obj = %ROOT%\obj\release;P:\Clarion5\obj\release
*.res = %ROOT%\obj\release
*.rsc = %ROOT%\obj\release

*.obj = %ROOT%\obj32;P:\Clarion5\Obj32\
*.res = %ROOT%\obj32
*.rsc = %ROOT%\obj32

*.obj = %ROOT%\obj32\release;P:\Clarion5\Obj32\Release
*.res = %ROOT%\obj32\release;P:\Clarion5\Obj32\Release
*.rsc = %ROOT%\obj32\release;P:\Clarion5\Obj32\Release

*.dll = .;%ROOT%\bin;P:\Clarion5\Bin;P:\Clarion5\3RdParty\Bin
*.tp? = %ROOT%\template;P:\Clarion5\TEMPLATE
*.trf = %ROOT%\template;P:\Clarion5\TEMPLATE
*.txs = %ROOT%\template;P:\Clarion5\TEMPLATE
*.stt = %ROOT%\template;P:\Clarion5\TEMPLATE
*.*   = .; %ROOT%\examples; %ROOT%\libsrc; %ROOT%\images; %ROOT%\template; %ROOT%\convsrc
*.lib = %ROOT%\lib;P:\Clarion5\3RdParty\lib
*.obj = %ROOT%\lib;P:\Clarion5\Obj32\Release
*.res = %ROOT%\lib;P:\Clarion5\Obj32\Release

moved Clarion5 from Drive P: to local drive C: and changed the red file but no luck. Created an empty c:\Clarion5\obj32\Release and tried to recompile. Looked in the Release folder and only the makem_rd.obj was created but the file length was zero(0).

Is it possible you don’t have 8.3 filenames enabled?

I had a strange problem like that in the past when I created a VM. The drive did not have 8.3 enabled by default. Here’s what I did:

On 5/18/2018 10:11 PM, Jeff Slarve wrote:


This fixed me up (on my drive E:) -

fsutil behavior set Disable8dot3 E: 0

After I enabled 8.3 creation, it worked.

Next time I create a drive, I’ll check to see if that’s an option to

One more thing this only happens on APP’s using Clarion Templates. APP’s using ABC Templates compile just fine.