ClaRunExt.DLLnot found

Greetings, I have a program which send out mails which works fine on a number of pc’s except on this Windows Server 2012 PC. It gives and error ClaRunExt.DLL could not be found.
I have tried installing c++ 2005,2013 redistributable, .net4.5 but no luck.
Any advice appreciated…

You didn’t say whether you confirmed that the ClaRunExt.DLL file exists in your application folder.

Hi yes , its there. Its just on this 1 particular pc where im having this issue

Maybe Process Monitor (aka procmon) could help you diagnose the problem.

If you’ve never used procmon, here’s a few tips to avoid problems:

  1. Use a good filter. I use “Process Name is myexe.exe”.
  2. Under the “Filter” menu, tell it to “Drop Filtered Events”. Otherwise you get thousands and thousands of events and it can bog down the system in very little time.
  3. Use Ctrl+E to enable/disable the capture of events.

As an aside, I get the following warning about the same file with every full compile. Don’t remember in which Clarion version it first began to display, but it’s been a long time. Always been curious if it is the same for everyone else.

clarunext.dll could not be copied. Error: The process cannot access the file because it is being used by another process.


Relating to the aside, yes I have been getting the same thing as totalhip for a long time when building a standalone exe. The build process copies the DLL to the output folder rather than work with it in the Clarion folders themselves. I don’t know why SV do this. The exe will certainly run when deployed elsewhere without it.

Regards Jim

Hi Kayjee,

The error is misleading - it’s not that the DLL is missing, but some of the VC++ dependencies can not be found.
This has come up several times on the newsgroups.

There’s an issue with clarunext and it’s dependancies upon VC++ runtimes that aren’t always present, and a separate issue with Server 2016.

Several threads in the Clarion10 newsgroup cover this eg

Subject ’ clarunext .dll could not be found in Terminal services’
From Jan K. van Dalen
Date 15/05/2018

Yep we’ve had this misleading error too.

Quote from my post of 22/02/2017
The trouble with the stuff in clarunext .DLL is that it has a dependancy upon certain VC++ runtimes and they’re not always present.
So you could end up having to run the setup exe on lots of workstations.

I spent several days creating a Clarion app to access an ASP.NET WebService using the WebRequest wrapper in clarunext .DLL - all worked fine on my machine and several machines at the client site and at work.
But some of the machines didn’t work and running the clarunext setup.exe program didn’t fix the problem on any of the Windows 10 machines.

There’s also an issue with Server 2016 and clarunext .dll
It’s built with a target of .NET 4.5 which doesn’t work/like Server 2016

Diego posted a .NET 4.61 version on this newsgroup in the thread subject
" clarunext .DLL on Server 2016" 26/09/2017

If you can find ClaRunExtSetup.exe try running that.


Thanks for the feedback, I manage to claRunExtSetup.exe, installed it rebooted server, but still no luck.
At a loss at the moment…

I finally resolved this.
I installed every C++ redistributable.
Here is link to download all c++ that worked for me if anybody else gets stuck with this.

DropBox Download

This is an old post. But it doesn’t seem to be answered.
The problem is, the error message is not correct. I suspect it wasn’t ever tested. I discover the error messae comes from the source code for clarunext. I wrote a little Clarion program that gives the correct error message for the error.
The error is encountered if you run your Clarion program on a Windows server.
The clarunext.dll is not missing. It is indeed on your server, and probably right there in your application folder.
The fix is easy. Copy the msvcr120.dll from your Window 11 (or 10) computer’s C:\Windows\SysWOW64 folder to the Windows Server, and put it in your application folder.
My msvcr120.dll is dated Feb 10, 2016 and has 971,584 bytes. -Bob