Ctrl-I is driving me crazy

Tags: #<Tag:0x00007fc0dc0ced20>

The Ctrl-I command in C11 is driving me crazy. It formats the same code differently depending on whether I am in “Source” or “Embeditor”. It doesn’t move comments when it moves other code. :upside_down_face:

Are there any tools that replace Ctrl-I with some sanity? Also, can I specify that all the comments on the same line as code should start at column 80 (or something) ?

What do other C11 users do?

Ctrl-I is for what? Have never been aware of such a beast.

Ctrl+I indents the code based upon your formatter settings. I’ve got it in Smart Formatter mode myself, which fairly closely aligns with my preferred coding style. Where it doesn’t, I’ve adjusted. :wink:

Okay. My quick test in a local procedure resulted in the CODE statement being moved to column 1.
Clearly not valid under any settings. Don’t think Ctrl-I is going to become a habit for me. :neutral_face:

Donn, perhaps tweaking the formatting settings might help. Here is what I use. While it isn’t perfect, it is at least consistent. Like I mentioned in our PM. The formatting definitely gets confused when you are in the Embed Tree vs. the full source.

1 Like

Yup, the Smart Formatting doesn’t work when editing a single embed via the embed tree. That’s why I’ll typically put a marker there so that I can find it, then visit there via the full Embeditor. IOW, I tend to use the embed tree only when I have to add a new embed that I can’t find easily in the Embeditor.

Unfortunately that’s not an option for global embeds, so I have to kick it in the pants occasionally.

Sadly, Ctrl-I is what happens when you press enter at the end of a line of code (by default). When I first started using Clarion I thought there must be some kind of mistake. I’ve gotten used to it, but I end up wasting a lot of time indenting stuff and moving comments around.

Thanks to @BoxSoft and @Rick_UpperPark for your suggestions. I’ll definitely have a look at those settings.

Don’t be sad, you can turn off Smart Indent in Options. I use Automatic.

I also uncheck the Cut/Copy as I often accidentally hit Ctrl+C with nothing selected when I meant to Ctrl+V Paste

I also UnCheck the “Insert Line Continuation after Enter”

2 Likes

I use “auto” setting, “smart” is not ok for me. But yes, I do use CTRL+I a lot.