CW Task Failure

compiler
Tags: #<Tag:0x00007f46d903fcd8>

#1

Getting the following error when compiling a DLL:

The “CW” task failed unexpectedly. (MSB4018) - C:\Clarion10\bin\SoftVelocity.Build.Clarion.targets:72,3

The DLL in question has dependencies on four addition projects which all compile, individually, without error. Two of the DLL’s are dependent upon the other two; so, they seem to be okay. I have checked for the existence of the 4 DLL’s and they all exist with appropriate compile times.

Any thoughts?


#2

Are you compiling from the IDE?

That error is coming from the build task that is used by MSBuild as far as I know.

Take a look at this: https://stackoverflow.com/questions/31608319/msbuild-error-msb4018-in-vs2015-the-link-task-failed-unexpectedly

Maybe check your cwproj file for anything weird?
Unless you have setup something fancy I think you can delete the cwproj and it will be recreated next time you open the app file.


#3

I tried to delete the .cwproj file and it does not recreate it. I have tried eliminating templates that weren’t absolutely necessary, cleaning the project, and numerous other “wild-hair” ideas to see if I could trigger a successful build. I have included the cwproj file for you to look at; but, I don’t see anything weird in it.

soefiles.zip (1.6 KB)


#4

Maybe check your bin folder for possible .xlog file(s)? If any new xlogs exist, you can sometimes get a clue by viewing it. You can open the xlog from within the IDE (File --> open file).


#5

Hi @Steve_Shurts

I have found when you need to re-generate the cwproj file you need to both delete the project and remove the app from the solution folder. Then add the app back to the solution folder, and at that point clarion will re-create the cwproj.

I hope that helps.

Regards

Mark


#6

I have same problem for a long time. This error is generating (for me) if I use national (Turkish) character on application name. But it’s compiling properly.