💫 Randy Rogers, Devuna - Code base available to the Clarion community


#1

Randy posted this to the skype chat groups a while ago and I asked, and received, permission to quote him here.
Since then he has been building up quite a set of repos on github which are well worth checking out.

Don’t forget to send @rrogers you thanks too. Thanks @rrogers !!! :slight_smile: :fireworks: :star:

I have been semi-retired for about three years now and I have decided to make my code base available to the Clarion community. I’ll be releasing things as quickly as I can get them ready on GitHub.

I have placed my first public code repository for Queue-Edit-In-Place on GitHub.You can find it here…


#2

The publishing of my ‘Clarion 3rd Party Tools’ is now complete. I have a few more odds and ends I may also publish as time permits. @Brahn Please post the appropriate links on ClarionHub.

Thanks @rrogers !

See the - Getting Started Guide


This page has all the repos:


For convenience, here are some direct links!


#3

#4

#5

#6

Hi, All!
I try to compile CyberTools example and get many errors “Error(3): cif$fileopen MONTHCALENDAR.INC System can’t find the path. - C:\Users\Public\Documents\SoftVelocity\Clarion10\accessory\Devuna\Examples\CiberTools\clw\CyberTools_xx.clw:1.”
Where can I find this file?


#7

I didnt have that error when I got KSS to build. I did have several others, but Randy quickly fixed those items. That path tells me that the files in KSS\libsrc\win may not be in your red. I had to move several class files to \accessory\libsrc\win and likewise, had to add an app-specific red to process \kss\libsrc\win and kss\lib


#8

Hi,

I tried adding CoolTips to my Multi-Dll system.
1) I added CoolTips Global Extension to my Data Dll that also contains CapeSoft WinEvent.
Getting Duplicate Errors on:

CW_USEDEFAULT
KEY_QUERY_VALUE

It compiled without any errors.

2) Compiling my Data Dll for the second time.
Getting 23 errors

typedef unsigned char byte;
Syntax error in #pragma command - C:\Clarion10\Accessory\LibSrc\Win\TTUTILLIB.C:2,1960
Declaration syntax error - C:\Clarion10\Accessory\LibSrc\Win\TTUTILLIB.C:25,23
typedef void far *    PDVI;
Syntax error, expected:  ; : [ ( { :: - C:\Clarion10\Accessory\LibSrc\Win\TTUTILLIB.C:25,9
Declaration syntax error - C:\Clarion10\Accessory\LibSrc\Win\TTUTILLIB.C:26,23
byte pascal CallDllGetVersion(byte (pascal *fpDllGetVersion)(PDVI), PDVI dvi);
Syntax error, expected:  <operator> . -> .* ->* [ ( ) , :: ... - C:\Clarion10\Accessory\LibSrc\Win\TTUTILLIB.C:28,74
byte pascal CallDllGetVersion(byte (pascal *fpDllGetVersion)(PDVI), PDVI dvi)
Syntax error, expected:  ; , ( [ <func-declarator> - C:\Clarion10\Accessory\LibSrc\Win\TTUTILLIB.C:30,13

and a lot more.

Anybody knows how to resolve these errors please.

Regards

Johan de Klerk


#9

Hello all!
I found the repos that Randy Rogers generously gave to community and tried to compile CyberTools example and I also get many errors
TPL: (PROG02.$$$) Error: ASSERT: %FixClassName: Cannot find class “kcrINIClass” on Procedure: “GUIDTOString2” - D:\Clarion\dev\Examples\c10\devuna\CyberTools\PROG02.$$$:1 (one time) and
Error(3): cif$fileopen MONTHCALENDAR.INC The system cannot find the path specified. - D:\Clarion\dev\Examples\c10\devuna\CyberTools\clean\clw\CyberTools.clw:1 (several times)
I searched in every repo of this utilities and found it nowhere,
Any one knows where can I find this file?

TIA
Theodore


#10

This template exists, but I don’t see the kcrINIClass module. https://github.com/Devuna/Devuna-Common/blob/master/template/win/KCR_INIClass.tpl

Maybe Randy knows? His email is on the github page.


#11

Hello jslarve

Thank you for answering… I have that file also (it was in the place), template is registered, but compilation has the problem… I’ll try to send an e-mail to Randy to inform him…

Theodore


#12

Sorry for late response…
Randy was very kind to answer my emails, regarding this problem… There were a couple of files missing which he’ll update on product’s github page…
After that, all is ok…
Thank you very much Randy :slight_smile:

Theodore


#13

Hi Theodore,

Do you know when Randy will update the site with the missing files?

I just checked and it does not seem to be updated yet.

Regards

Johan de Klerk


#14

Hello Johan

Sorry for late response, just returned from short vacations…
Unfortunately, I don’t know when he’ll do that…
In the mean time, I’d send you the missing files if you need them…
Just pm me the e-mail address…

Theodore


#15

Hi Theodore,

Thanks.

I have sent you a PM.

Regards

Johan de Klerk


#16

For those interested in the open source version of KSS, a fork of it is available with an installer at https://github.com/mriffey/Devuna-KwikSourceSearch The installer downloads are at https://github.com/mriffey/Devuna-KwikSourceSearch/releases

At the moment, it is still in app format, so accommodating pull requests is kind of a serious effort. I plan to move it to a hand code project by virtue of building from the generated code rather than from the app. The repo will make note of that when it happens.