DLL Compile loosing compile settings


Bruce mentioned it in one of the Webinars that you have to do something so get the DLL to compile correctly again. Can anybody maybe remember the Webinar or the settings you have to go to get it to compile the DLL as DLL again and not as nothing.

One of my Muti DLL project does not compile, .MAP .LIB is missing…other Multi DLL Projects compiles 100%, checked settings and all matches.

Thank you in advance…

On Project menu open Project Options.

Make sure you have a “Target Name” entered. IIRC its probably blank and build fails. Also check that “Output Type” is DLL. Review the Compiling tab also. If that doesn’t fix it then post screen capture of those 2 project tabs.

I believe the problem Marius is describing is that sometimes entries you make into the Compile Defines list manually disappear.
The values inserted by templates never disappear.
My solution for this is to write a small template where I can check off which compile defines I want in the app and then use #PRAGMA to generate them into the project.

1 Like

I think what Marius is referring to is a comment I made in part 2 of my Multi-DLL series.
What happened at the end of part 1 (which I then described in part 2) is that the app got itself into “exe output” mode, even though the project said “dll output”.

The solution was to change to Exe Output, close the project settings, then go back to project settings and change back to DLL output. That seemed to be effective.

Thank you all for the replies, but it seems to have something to do with the NEW Clarion (13788).

Copied my DLL (APP’s) back to the previous version (13768) - and the DLL compiles 100%, copied the same DLL (APP’s) and project files to new Clarion and the MAIN DLL of one of my project does not compile as DLL. Tried all the above and still nothing, not sure what causes it, but for now revered back to previous version.

FYI Tried copying the full folder as is in old version to new version and just press compile in new clarion but still the main DLL keeps on compiling itself as nothing, no output or errors to report. => Just compile complete. NO DLL OR EXE FOUND no where on my system. Strange thing is, that all the modules keeps on compiling from scratch, (file does not exists)

The APP has a Project inside it that sometimes gets out of sync with the .CwProj file

You could try deleting** the CwProj and SLN (** move them to a subfolder “OldPrj” … do NOT delete)

Open the APP and it will recreate the CwProj and SLN

I then do a compare of the new and old CwProj files (since they are XML) to see if anything appears to have been missed. Can compare SLN also but typically not much there. These compares may give you somethings to bug report to SV.