Freeimage - error when compiling - [email protected] not found


Any ideas?

Translated it says Entry point [email protected] not found in DLL libery.
Version 3.15.8

Regards Niels

FreeImage.dll v3.15.0.0 has Freeimage_RotateClassic entry.

Last year someone asked about this on the newsgroups.

Charles Edmonds replied:

I ran across that and fixed it for Larry several months ago and sent him
the updated files, but I guess he has not gotten around to updating the
installer yet.

You can download the modified class files and a new LIB file here:

IIRC the .RotateClassic method was deprecated and removed.

I updated the classes to use the .Rotate command with the proper syntax and
it seems to work fine.

I hope that helps!


This was the thread:

From: Charles Edmonds [email protected]
Subject: Re: FreeImage - Entrypoint Not Found
Newsgroups: softvelocity.clarion.third_party
Organization: LANSRAD (remove the ByteMeSpammers to email me)
Date: 22 Oct 2020 14:35:20 -0400


Geoff R

1 Like

Thansk Geoff. Now it works.

1 Like