Import special characters

Hi, i must be missing something.

I do have an app, that will import Ascii/Excel files, works great!

Now i made another app, also with import function, but this one has a problem with special characters.
So ö becomes ö and also ë, ü etc. will be changed.

I tried SYSTEM{PROP:CharSet}=CHARSET:DEFAULT and a lot of other things.
Nothing worked.

Anybody to help me?

Thanks in advance,

Show your file declaration. If it has OEM that could be the problem.

Thanks Carl,

I forgot to mention both app’s has the same dct so the same settings for the files (no OEM).


In order to understand what is going on here, you need to understand about string encodings. I heartily recommend watching webinars #583 then #584.!583!584

The short version is that the character encoding in the file you are importing does not match the encoding that you are displaying the data as. (Also potentially the encoding you are using for storage.)

In 100% of cases like this the issue is always that you are not using the correct encoding in the appropriate places.

Hi Bruce,

That’s indeed the problem. So far i managed to get it better with StringTheory Utf8ToAnsi encoding.
It’s not perfect yet, but at least it looks better now.
I’ll watch the clarionlive webinars, that might give me better insights.