MSSQL is not a registered file driver

Can anyone steer me in the right direction with this please?
MSSQL is in the register file drivers list and in the register dictionary file drivers list and is assigned to the project. When I try and compile the project I get “MSSQL is not a registered file driver”.
I should add that this is a brand new install of Clarion 11.
I have registered file drivers as far as I can see and brought a sloution from Clarion 10. The dictionary has been updated.


Sorry, never done this, or at least I do not remember, but I remembered that I have seen something in the help the other day.

I would suppose that these registering/unregistering leaves traces in regedit

Where are you installing Clarion 11 and what Build of Clarion 11 are you using?

Don’t install below ‘\Program Files’ instead use a unique sub-folder like
C:\CW13744 or
C:\CW13758 etc etc

You can have multiple installations of Clarion on the same machine without them interfering with each other.
Just install into a fresh folder and make sure you use the /ConfigDir switch on your desktop shortcut so that all the settings go into a separate \Settings folder below the %ClarionRoot%\Bin folder eg

NB note there’s a space between Clarion.exe and /ConfigDir

There are 2 places you need file drivers registered. The Dictionary File Drivers menu choice is underneath the other one.

Clarion in folder C:\Clarion11.1.
Microsoft SQL is in file drivers and dictionary drivers.

I have just set up a new windows 10 vm from scratch and installed Clarion in folder C:\Clarion11.1.
Microsoft SQL is in file drivers and dictionary drivers.
MSSQL is assigned to the project as a file driver.
I still get ‘MSSQL is not a registered file driver’.
Does anyone have any ideas?


Have you tried removing all the file drivers, restarting then adding them all in again?
I know I’ve had this problem before, but I can’t remember how I fixed it

Hi Sean
Yep tried that too.

The correct driver is in the app folder?

I think you’ve got a bad installation file or maybe your Anti-Virus is blocking/deleting stuff?

In your %ClarionRoot%\Bin folder you should see the following 2 files for Build 13758

CLAMSS.dll File Version Size 271KB - MSSQL Database Driver
Clamsss.dll File Version Size 75.5KB - MSSQL Dictionary Driver

Do you see those 2 files and are the details correct?

For what it’s worth. I did a clean install on 11.1.13758. Opened a project, added a mssql table to the dictionary of a example project and compiled cleanly.

If you are using EXE compression tool like UPX, compressed DLL driver generates that type of error. In that case you should keep original drivers uncompressed.

Hi Rick
Interestingly if I delete the dictionary file driver for Microsoft SQL Server then close and re-open Clarion, the driver is back.


If I create a new dictionary and add a table I don’t see the Microsoft SQL driver in the list even though it is in the list in Register File Drivers and Dictionary File Drivers.


Looks ok to me.

Those same files are in your app folder?

I updated the dlls in the folder where my app is built and SOLVED.