On screen keyboard

Seems that Clarion integrated option OnScreenKeyboard doesn’t work on windows 10 anymore. In latest version 11.13505 there are some changes. Now it works in win7. On-screen keyboard jumps up when focus is on entry field (and it’s annoying too because you have to close it on x every time), but it doesn’t work in win10 at all (not in tablet or desktop mode). I would like on-screen keybord to open when focus is on entry field and automaticly close when out of focus, like it’s supposed to work. Any ideas?

First off, SV made the mistake (IMO) of using the term “On Screen Keyboard” for what was being shown.

Windows does have an On Screen Keyboard (OSK.exe) there is a short cut found in %Appdata%\Microsoft\Windows\Start Menu\Programs\Windows Ease of Access\On-Screen Keyboard which points to %windir%\system32\osk.exe

IIRC SV is running TabTip - the Tablet Text Input Panel aka the “Touch Keyboard and Handwriting Panel” found in C:\Program Files\Common Files\microsoft shared\ink\TabTip.exe

IIRC you could run TabTip and the touch keyboard would appear on screen. That doesn’t seem to be happening. I can see TabTip.exe in the TaskList but it’s not visible until I click on the Keyboard pinned to the taskbar. Also clicking on the same place will hide a visible touch keyboard.

Here are some programmatic approaches to showing the Touch Keyboard
While the article is roughly 2.5 years old, there may be some relevance to it.

That same article claims making this registry change will restore the old behavior of making TabTip visible when you run it.

I haven’t tested this… what they suggest,
I haven’t tried to port it

Note: that same article mentions
But I think they got the location wrong, I think it should be
So take what they wrote with healthy skepticism

There is a link to the following repo in the article…

While this is about WPF, it might give you some a head start in finding some appropriate documentation.


It seems on-screen keyboard works best for me when in GlobalProperties OnScreenKeyboard is set to Off. In this case when app is running on latest windows 10 versions it pops up when focus is on entry and auto hide when not needed. In windows 7 you get keyboard icon next to field. I can live with that. But on some windows 10 it doesn’t work, no matter what setting is under Windows Setting Typing.