Problem with reading SQLite virtual table From Clarion 6.3 application


First I used SQLite3 ODBC driver to connect my application to an SQLite table and it was perfect using direct browsing (adding the table to the dictionary) or directly with prop:sql.

But when I tried to read the virtual table in the same DB, I am getting this error: no such module: fts5

after doing some research I found that SQLite FTS5 Extension should be installed, but I could not find from where to get it.

I am using Clarion 6.3 and SQLite3 ODBC driver

Thank you.


John covered part of this during last Wednesday’s Open Webinar (not the c6 usage, but the fts5) - it’s available via the Clarion Live youtube channel.

Hope it helps,



I will check it thank you

I checked that live and it was nice. The problem is that in clarion 6.3 SQLite was not included in the supported databases yet, so I had to use ODBC.



Still searching but no luck.

Any Ideas?


The sqlite3.dll in my demo repo has FTS5 compiled in. I think I just got that from the latest release at the time. I didn’t do anything to add FTS5.


Thank you for your reply.

I think this thing is solved in later clarion versions of clarion but not in 6.3 as SQLite was included in those versions so I had to use ODBC instead.


Not sure whether or not FTS5 can be used via ODBC, but you’d certainly want to use an sqlite dll that has that feature enabled before testing it. Not sure you’d do anything different through ODBC as far as PROP:SQL goes.

Try using the sqlite odbc dll found at SQLite-ICU-MinGW/bin-SQLiteODBC-Win-x32x64 at master · pchemguy/SQLite-ICU-MinGW · GitHub

It has the FTS5 module included and active.

1 Like

Thank you. I will check that soon.


It is working fine.

Thanks a lot.

Best Regards