Syntax Error: Corrupt Pragma String - PRAGMA('#Ignore filename.clw')

Tags: #<Tag:0x00007f2253b256e8>

This post ties into this post Is it possible to override the AppGen PRoJect system? - questions - ClarionHub

So the command Pragma suggest you can insert compiler directives from source code files (.CLW’s).

PRAGMA Send to the project system a statement from your generated source code
PRAGMA(‘compile(string)’)
Equivalent to PRAGMA(‘project(#compile string)’)

#Ignore filename.clw suggests its a valid see the help document “Basic Compiling and Linking”

Compile and Link Commands
Whenever a file is compiled or linked, the current settings of the compiler or linker options (#pragma settings) are compared to those used when the file was last compiled or linked, to determine whether the file is up to date. If a compile or link is necessary, the current settings are passed on to the compiler or linker.

#ignore
#ignore
#ignore #pragmastring
There are two forms of the #ignore command. The first, where a filename is specified, tells the Project System to ignore the date of the nominated file when deciding whether or not to compile. This is useful when a ‘safe’ change is made to a widely used header file, to prevent mass recompile.
The special form #ignore #pragmastring directs the Project System to ignore the #pragma settings when deciding whether or not to compile a file. This may be useful, for example, when a new compile-time macro has been defined, but there is no need to recompile everything.

so I’ve added it to the PRAGMA command but the compiler throws a syntax error citing its a corrupt pragma string

PRAGMA(’#Ignore filename.clw’)

#Template code
#For(%Module)
PRAGMA(’#IGNORE %module’)
#EndFor

The #Ignore is added to the first clw that is generated and then compiled but even adding #Ignore filename.clw to the project system throws the error.

Am I doing it all wrong or is this a bug?

TIA

Richard,

try
PRAGMA('ignore(filename.clw)')

That doesnt throw a compiler error now, but the compiler stills tries to compile the file it should be ignoring.

I’ve tried all these combinations
PRAGMA(’#Ignore(Filename.clw)’)
PRAGMA(’#Ignore(C:\Folder\Filename.clw)’)
PRAGMA(‘Ignore(Filename.clw)’)
PRAGMA(‘Ignore(C:\Folder\Filename.clw)’)

Its not picky over the hash is it?

Edit

I did see in ABfile.tpw this
PRAGMA('define(init_priority=>3)')

But I dont think its working.