Window Previewer

Today I was trying to use the Window Previewer and pressing the button does not work. I was thinking if the problem arises with the latest update of Windows 10? I tried reinstalling Clarion 11 but it’s the same, it happens with Clarion 10 too. I tried on a virtual machine with Windows 7 and it works fine.

Hi Martin,

When you click the Previewer button Clarion creates several temporary files in the folder.
Namely a .CLW file (containing the Window declaration and controlling code), and a project file .CWPROJ
Using those two files Clarion then compiles an EXE and creates a shortcut and a manifest.

All this action takes place (by default) in the folder where the example is stored - the .CLW and .CWPROJ files are auto-deleted - but whilst the preview window is open the .EXE should still be there.

It will be randomly named but start with WinPreview followed by an extended GUID eg


Do you see any files in the Examples\School folder whose names start with ‘WinPreview’ ?
Where have you installed Clarion - hopefully not below program files?
Check your anti-virus excludes all the \Examples folders as it’s possible it’s preventing Clarion from creating the temporary files and compiling the project.

Hi, thanks for answering, Clarion is installed in C: \ Clarion11 I tried several examples and it doesn’t work, disabling antivirus either, very rare!

Hi all,

I am pretty certain this is a Windows upgrade issue.

I remember this working with my current Clarion 11 then one day it stopped. I assumed it was something to do with a Windows upgrade but since I didn’t notice exactly when it stopped I can’t say which upgrade.I am on Windows 10 Pro, 6.2.18363 SP0 now.

I have vague recollections that sometime in the past it stopped then returned with a further upgrade too.

Regards, Jim

Yesterday at a certain point Clarion showed me an exception that said I did not have sufficient permissions to write to the AppData / Roaming / SoftVelocity / Clarion / 11.0 directory, it told me that I had to change the directory, I was investigating but I don’t know where to save that configuration so that The preview can write the file!

Hi Martin,

The Previewer writes it’s files into the folder where the APP lives, not into AppData.

If you’re getting exceptions about writing to \AppData you can always use the ConfigDir switch on your desktop icon to move the settings below the %ClarionRoot%\bin folder.

Right - Click on the Clarion desktop icon, select Properties and change the Target setting to add the /ConfigDir switch eg

C:\Clarion 11\bin\Clarion.exe /ConfigDir
NB there’s a space between .EXE and the /ConfigDir

Now the settings will be stored in the C:\Clarion 11\bin\Settings folder and not below Appdata

Hi Graham, I had tried that but it didn’t work for me either. I was looking in the Clarion11 / bin directory and found an .xlog file when opening it with Clarion says:

Clarion Version:
.NET Version: 4.0.30319.42000
OS Version: Microsoft Windows NT 6.2.9200.0
Current culture: Spanish (Spain, International Sort) (es-ES)
Current UI language: en
Working Set Memory: 293420kb
GC Heap Memory: 25201kb

Unhandled Exceptions
UnhandledException caught in QuietMode do not Terminate
ThreadException caught
Exception Type: System.IO.FileNotFoundException
File Not Found: Microsoft.Build.Utilities, Version =, Culture = neutral, PublicKeyToken = b03f5f7f11d50a3a
Error Message: Could not load file or assembly ‘Microsoft.Build.Utilities, Version =, Culture = neutral, PublicKeyToken = b03f5f7f11d50a3a’ or one of its dependencies. The system cannot find the specified file.

I finally installed Visual Studio .NET 2015 since it was a new PC and I didn’t have it installed and now it works. It seems that the problem is that Microsoft.Build.Utilities cannot find it. At least now it works!

BTW, look at your compiler output pane. Sometimes you’ll see errors when compiling the preview window, usually due to use of equates or images that aren’t found.