Windows does not have access to the specified device path or file

I’m a bit lost on how to solve my problem and not even sure it has anything to do with Clarion - but now I’m trying.
When I compile my app it runs fine the first time. If I run it again immediately after, I get the above error. 20-30 minutes later it can run it again. I have administrator rights on the PC and it runs standard Microsoft Security.
Someone who has experienced something similar and maybe has an idea how to solve it.
On the web, reference is made to 5 general solutions. I have tried them all.

Regards Niels

The only other thing I can possibly think of…

Does the app have a manifest?

Probably has nothing to do with the error.

Try out “OpenedFilesView” from to see which files are in use by your app.
You could also try to use “Process Explorer” from

These are tools that help to better understand what your app is accessing.

Maybe your app tries to open a file for which the file path is not set correctly.

I’ve tried both with and without manifest, but it doesn’t change anything.
But thanks for the input.

It is the world’s simplest Nettalk Webserver which does nothing but display an empty form.
And it doesn’t really make sense that it works after 30 minutes - always.
I have also tried with other Nettalk examples and it gives the same result.
My own thought is that it has something to do with Windows Defender but unfortunately, I don’t have the option to turn it off - but that’s just a guess.

But thanks for the input.

Have you checked your A/V Firewall apps? Might need to add your folder to the ignore list(s)

Is the file in question somewhere under c:\program files folder?

Maybe you’re trying to access a file using a relative path, and the base path changes due a SETPATH or open a file/folder wich is setted to remember the last path used…

Just my 0.02
Best regards…