Windows Server 2019 does not interpret UTF-8

Hello everyone, I’m using a VPS that apparently Windows Server 2019 does not interpret UTF-8 does anyone know how to solve this?
Below is an image of a window made in CW 9.

This only happens on VPS.

In the string would be
Última leitura

Do you assign like this? It’s possible that the server’s language does not support “Ú” character.

?Prompt1{prop:text} = 'Última leitura'

Exactly, but the strange thing is that everything is in Portuguese on the VPS…

the above code is also not handled on the server…


Would be: Última leitura 27/06/23 às 18:30 …

Language of windows server…


I tried using json::ToUTF() and json::FromUTF(), but without success…

In the cod I generate an html, which is with “?” in the characters, but if I copy it to my computer the “?” add up and my computer’s windows already resolves all the characters… could it be a VPS Server Bug?

File in the VPS…

Same file in my computer…

Hi, have you tried unchecking that option Beta: Usar Unicode UTF-8 … ?

No… I’ll try but it has to be at another time because I have to restart windows…
I did a test in a notepad there on windows and it was normal…
Is it some configuration in Clarion…?

because notepad is Unicode and that setting is for non-unicode programs

1 Like

Like @FedericoNavarro said, you need to uncheck beta UTF

Ok I will try and come back to tell you the result, thank you all.

Hello everyone, it was only today that I managed to restart to see if unchecking the Beta UTF worked.
Apparently it worked, that’s all.
Thank you very much to all