Running the debugger in a debugg state

Tags: #<Tag:0x00007fc0e3ea8048> #<Tag:0x00007fc0e3cd6490>

Hi everyone,

Lately, I’m having a strange behavior with the debugger project state, it keeps getting back to the release mode even with the project set in Debug mode. When we run in debug mode we should expect having the four windows that we usually have, they are not appearing. The program is starting in release mode instead of Debug mode. I find this unusual.

Here’s what I’m having as a message in the Debugger window

RACE - C:\Users\Public\Documents\SoftVelocity\Clarion11\Examples\PEOPLE\D32.LOG

start process C:\Users\Public\Documents\Sof tVelocity\Clarionll\Examples\PEOPLE\people.exe

Command line :> “C:\Clarionll\bin\Cladb.exe” -s Release -c “C:\Users\Joliciel\ÀppData\Roaming\SoftVelocity\Clarion\ll.0” Command line :> “C:\Users\Public\Documents\SoftVelocity\Clarionll\Examples\PEOPLE\people.exe”

Redirection file :>

CREATE_PROCESS_DEBUG_EVENT ! No image name found

g.debug_name C:\Users\Public\Documents\Sof tVelocity\Clarionll\Examples\PEOPLE\people.exe BaseOfImage 008Ä0000

CREÀTE_PROCESS_DEBUG_EVENT: process main thread tid=00004974 thread handle=00000628

My observation regarding the debugger parameter at the Command Line it should be “Cladb.exe -s Debug” instead of “Cladb.exe -s Release”.

I though the problem was coming from the Softvelocity AppData subfolder. I have checked all folders attribute within the AppData they are hidden. Meaning even if we see the folder as read-only the attribute of the AppData is hidden; meaning we can write within the folder. I’ve tried a symbolic link forwarding the folder externally to the AppData, it did not help, at runtime the app state still in release mode even with the Debug selection, it needs to be reselected every time that I want to run the debugger.

I thought the problem was coming from Windows. I’ve checked the Windows health image with the following commands.

DISM.exe /Online /Cleanup-image/Scanhealth
DISM.exe /Online /Cleanup-image/Restorehealth
DISM.exe /Online /Cleanup-image/startcomponentcleanup
sfc/scannow

Even with a clean image the issue with the Debugger state won’t change, also with a reinstallation of Clarion after the cleanup.

Thank you,
Robert

Your build configuration is set for debug?

e.g.

“Build” menu --> “Set configuration” --> Debug

Thank you Jeff for your help. I’ll keep this in mind.

Meanwhile, I found the cause that was preventing Clarion to load the debugger properly, the anti-virus blocked it. The anti-virus was avoiding the file Clardbrun.dll from loading when Clarion was calling the DLL. To restrict this from happening, what we have to do in the anti-virus program, we need to add the file in the trust list, and making sure it allowed and not restricted. This way on the next call it will skip it.

1 Like